aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Crichton <alex@alexcrichton.com>2019-01-08 15:24:40 -0800
committerGitHub <noreply@github.com>2019-01-08 15:24:40 -0800
commit56f9afb4d2abdf38ed3caf9f819ac8bacc290940 (patch)
tree8b982602f331d2c1df97121b2f2b971dc39bc68d /Cargo.toml
parentd0977ab1dd9720c572b2d54a51196fcdf38f7544 (diff)
parent0372ba6925aa2c6db4d27022562064e25cdc5312 (diff)
downloadmilf-rs-56f9afb4d2abdf38ed3caf9f819ac8bacc290940.tar.gz
milf-rs-56f9afb4d2abdf38ed3caf9f819ac8bacc290940.zip
Merge pull request #278 from Kerollmops/master
Add the preserve_order feature (rebased version)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 10 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e91d917..408337d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "toml"
-version = "0.4.10"
+version = "0.5.0"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
license = "MIT/Apache-2.0"
readme = "README.md"
@@ -23,7 +23,16 @@ travis-ci = { repository = "alexcrichton/toml-rs" }
[dependencies]
serde = "1.0"
+linked-hash-map = { version = "0.5", optional = true }
[dev-dependencies]
serde_derive = "1.0"
serde_json = "1.0"
+
+[features]
+default = []
+
+# Use LinkedHashMap rather than BTreeMap as the map type of toml::Value.
+# This allows data to be read into a Value and written back to a TOML string
+# while preserving the order of map keys in the input.
+preserve_order = ["linked-hash-map"]