aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 8 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 131ebaf..3c7a665 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,16 +1,15 @@
[package]
-name = "toml"
+name = "milf"
version = "0.5.8"
-authors = ["Alex Crichton <alex@alexcrichton.com>"]
+authors = ["boringcactus <melody@boringcactus.com>"]
license = "MIT/Apache-2.0"
readme = "README.md"
keywords = ["encoding"]
-repository = "https://github.com/alexcrichton/toml-rs"
-homepage = "https://github.com/alexcrichton/toml-rs"
-documentation = "https://docs.rs/toml"
+repository = "https://code.boringcactus.com/misc/milf-rs/"
+documentation = "https://docs.rs/milf"
description = """
-A native Rust encoder and decoder of TOML-formatted files and streams. Provides
-implementations of the standard Serialize/Deserialize traits for TOML data to
+A native Rust encoder and decoder of My INI-Like Format (MILF)-formatted files and streams. Provides
+implementations of the standard Serialize/Deserialize traits for MILF data to
facilitate deserializing and serializing Rust structures.
"""
categories = ["config", "encoding", "parser-implementations"]
@@ -30,7 +29,7 @@ serde_json = "1.0"
[features]
default = []
-# Use indexmap rather than BTreeMap as the map type of toml::Value.
-# This allows data to be read into a Value and written back to a TOML string
+# Use indexmap rather than BTreeMap as the map type of milf::Value.
+# This allows data to be read into a Value and written back to a MILF string
# while preserving the order of map keys in the input.
preserve_order = ["indexmap"]