aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMelody Horn <melody@boringcactus.com>2021-12-03 23:30:52 -0700
committerMelody Horn <melody@boringcactus.com>2021-12-03 23:30:52 -0700
commitce5be7f783ac7c6589b501433caafd717c6e119f (patch)
treec6827e1c8b4679501d317a8ab6e1f4a2b136dae0 /Cargo.toml
parent7cc6b6414d30e95e763baadee2f493c8f69329ac (diff)
downloadqueue-go-brrr-ce5be7f783ac7c6589b501433caafd717c6e119f.tar.gz
queue-go-brrr-ce5be7f783ac7c6589b501433caafd717c6e119f.zip
swag
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 767c8b8..73a2795 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,14 +2,15 @@
name = "queue-go-brrr"
version = "0.1.0"
authors = ["Melody Horn <melody@boringcactus.com>"]
-edition = "2018"
+edition = "2021"
[lib]
crate-type = ["cdylib", "rlib"]
[dependencies]
base64 = "0.13.0"
-gloo = "0.4.0"
+chrono = { version = "0.4.19", features = ["wasmbind"] }
+gloo = { version = "0.4.0", features = ["futures"] }
image = "0.23.14"
imageproc = "0.22.0"
js-sys = "0.3.55"
@@ -30,6 +31,9 @@ web-sys = { version = "0.3.55", features = [
"HtmlCanvasElement",
"CanvasRenderingContext2d",
"Blob",
+ "MouseEvent",
+ "Event",
+ "CssStyleDeclaration",
] }
# The `console_error_panic_hook` crate provides better debugging of panics by