aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMelody Horn <melody@boringcactus.com>2021-03-27 09:02:59 -0600
committerMelody Horn <melody@boringcactus.com>2021-03-27 09:02:59 -0600
commit4e79ab051917fece21fcec0bd31cc2942462fda0 (patch)
treef2fad4c246cf8f4c7c4f7bc8b3f0e38a5b421079 /Cargo.toml
downloadwebget-4e79ab051917fece21fcec0bd31cc2942462fda0.tar.gz
webget-4e79ab051917fece21fcec0bd31cc2942462fda0.zip
rough draft
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..b34c1c5
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "webget"
+version = "0.1.0"
+authors = ["Melody Horn <melody@boringcactus.com>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1"
+fehler = "1"
+futures = "0.3.13"
+hyper = { version = "0.14.5", features = ["client", "http1", "runtime", "stream"] }
+mime2ext = "0.1.2"
+tokio = { version = "1", features = ["full"] }
+structopt = "0.3.21"