aboutsummaryrefslogtreecommitdiff
path: root/bird-machine-macros/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'bird-machine-macros/Cargo.toml')
-rw-r--r--bird-machine-macros/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/bird-machine-macros/Cargo.toml b/bird-machine-macros/Cargo.toml
new file mode 100644
index 0000000..e45569b
--- /dev/null
+++ b/bird-machine-macros/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "bird-machine-macros"
+version = "0.1.0"
+authors = ["boringcactus / Melody Horn <melody@boringcactus.com>"]
+description = "proc macros for bird-machine"
+edition = "2018"
+
+[lib]
+proc-macro = true
+
+[dependencies]
+regex-syntax = "0.6"
+proc-macro2 = "1.0"
+quote = "1"
+syn = "1.0"