aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMelody Horn <melody@boringcactus.com>2021-04-01 23:10:10 -0600
committerMelody Horn <melody@boringcactus.com>2021-04-01 23:10:10 -0600
commitd12f9f563968ea8471b4929936ac4f8553810428 (patch)
tree39f8f42eb840c32acb542bfc6314e2950e1e17e0 /Cargo.toml
parent543124c62c8123bd67e90bbc710aa064c6c5e271 (diff)
downloadmakers-d12f9f563968ea8471b4929936ac4f8553810428.tar.gz
makers-d12f9f563968ea8471b4929936ac4f8553810428.zip
put extensions behind a feature
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 41f2334..c76af6b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,10 +10,14 @@ license-file = "LICENSE.md"
keywords = ["build", "make"]
categories = ["development-tools"]
+[features]
+default = ['full']
+full = ['dirs', 'glob']
+
[dependencies]
-dirs = "3.0.1"
+dirs = { version = "3.0.1", optional = true }
eyre = "0.6.5"
-glob = "0.3.0"
+glob = { version = "0.3.0", optional = true }
jane-eyre = "0.3.0"
lazy_static = "1.4.0"
nom = "6.1.2"