aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMelody Horn <melody@boringcactus.com>2024-11-10 15:16:49 -0700
committerMelody Horn <melody@boringcactus.com>2024-11-10 15:16:49 -0700
commite9080b515d86b9f39e97d4c8e1a157dfa4ba86f3 (patch)
tree99634b948fe370bd1d0e7e33bdbacc09fa937454 /Cargo.toml
parent117c76f28bdad33d96d2ecbd410497d9cdee4ce9 (diff)
downloadmakers-e9080b515d86b9f39e97d4c8e1a157dfa4ba86f3.tar.gz
makers-e9080b515d86b9f39e97d4c8e1a157dfa4ba86f3.zip
upgrade from structopt to clap 4
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 45834b1..b684995 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,6 +15,7 @@ default = ['full']
full = ['dirs', 'glob']
[dependencies]
+clap = { version = "4.5.20", features = ["derive", "wrap_help"] }
dirs = { version = "5.0.1", optional = true }
env_logger = "0.11.5"
eyre = "0.6.12"
@@ -24,7 +25,6 @@ lazy_static = "1.5.0"
log = "0.4.22"
nom = "7.1.3"
regex = "1.11.0"
-structopt = "0.3.26"
[dev-dependencies]
tempfile = "3.13.0"