aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVincent Prouillet <vincent@wearewizards.io>2018-05-14 16:59:24 +0200
committerClément Renault <renault.cle@gmail.com>2018-12-28 14:42:55 +0100
commit06f916cb60808edba0690a91430cef40a5fdfdd4 (patch)
tree1ff6106c6f76222bd08dffc12fd1d69b5db8589d /Cargo.toml
parentc1a369f44762045e65989caa9491e153d1f358e6 (diff)
downloadmilf-rs-06f916cb60808edba0690a91430cef40a5fdfdd4.tar.gz
milf-rs-06f916cb60808edba0690a91430cef40a5fdfdd4.zip
Add the preserve_order feature
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 10 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9904e2f..39dae2d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "toml"
-version = "0.4.10"
+version = "0.5.0"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
license = "MIT/Apache-2.0"
readme = "README.md"
@@ -20,7 +20,16 @@ travis-ci = { repository = "alexcrichton/toml-rs" }
[dependencies]
serde = "1.0"
+linked-hash-map = { version = "0.5", optional = true }
[dev-dependencies]
serde_derive = "1.0"
serde_json = "1.0"
+
+[features]
+default = []
+
+# Use LinkedHashMap rather than BTreeMap as the map type of toml::Value.
+# This allows data to be read into a Value and written back to a TOML string
+# while preserving the order of map keys in the input.
+preserve_order = ["linked-hash-map"]