aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMelody Horn <melody@boringcactus.com>2021-12-03 19:33:19 -0700
committerMelody Horn <melody@boringcactus.com>2021-12-03 19:33:19 -0700
commit7cc6b6414d30e95e763baadee2f493c8f69329ac (patch)
treec0315d4c9d46caee9a96ee681a0be0a8b9960b7b /Cargo.toml
downloadqueue-go-brrr-7cc6b6414d30e95e763baadee2f493c8f69329ac.tar.gz
queue-go-brrr-7cc6b6414d30e95e763baadee2f493c8f69329ac.zip
piss
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..767c8b8
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,53 @@
+[package]
+name = "queue-go-brrr"
+version = "0.1.0"
+authors = ["Melody Horn <melody@boringcactus.com>"]
+edition = "2018"
+
+[lib]
+crate-type = ["cdylib", "rlib"]
+
+[dependencies]
+base64 = "0.13.0"
+gloo = "0.4.0"
+image = "0.23.14"
+imageproc = "0.22.0"
+js-sys = "0.3.55"
+wasm-bindgen = "0.2.63"
+wasm-bindgen-futures = "0.4.28"
+web-sys = { version = "0.3.55", features = [
+ "Window",
+ "Navigator",
+ "MediaDevices",
+ "DisplayMediaStreamConstraints",
+ "MediaStream",
+ "MediaStreamTrack",
+ "Document",
+ "Element",
+ "HtmlVideoElement",
+ "HtmlMediaElement",
+ "EventTarget",
+ "HtmlCanvasElement",
+ "CanvasRenderingContext2d",
+ "Blob",
+] }
+
+# The `console_error_panic_hook` crate provides better debugging of panics by
+# logging them with `console.error`. This is great for development, but requires
+# all the `std::fmt` and `std::panicking` infrastructure, so isn't great for
+# code size when deploying.
+console_error_panic_hook = "0.1.6"
+
+# `wee_alloc` is a tiny allocator for wasm that is only ~1K in code size
+# compared to the default allocator's ~10K. It is slower than the default
+# allocator, however.
+#
+# Unfortunately, `wee_alloc` requires nightly Rust when targeting wasm for now.
+wee_alloc = { version = "0.4.5", optional = true }
+
+[dev-dependencies]
+wasm-bindgen-test = "0.3.13"
+
+[profile.release]
+# Tell `rustc` to optimize for small code size.
+opt-level = "s"