aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 6 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ddb4cdb..5e0cf6f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,12 +7,11 @@ edition = "2018"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-barrel = { version = "0.6.5", features = ["sqlite3"] }
+barrel = { version = "0.6.5" }
chrono = { version = "0.4", features = ["clock"] }
-diesel = { version = "1.4.4", features = ["sqlite", "chrono"] }
+diesel = { version = "1.4.4", features = ["chrono"] }
hyper = { version = "0.14", features = ["full"] }
-# TODO not this
-libsqlite3-sys = { version = "0.22.2", features = ["bundled-windows"] }
+libsqlite3-sys = { version = "0.22.2", features = ["bundled-windows"], optional = true }
quote = "1.0"
structopt = "0.3.21"
syn = { version = "1.0", features = ["full", "extra-traits"] }
@@ -22,3 +21,6 @@ warp = "0.3"
[dev-dependencies]
rand = "0.8.3"
+
+[features]
+sqlite = ["barrel/sqlite3", "diesel/sqlite", "libsqlite3-sys"]