aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMelody Horn <melody@boringcactus.com>2020-12-24 05:53:02 -0700
committerGitHub <noreply@github.com>2020-12-24 05:53:02 -0700
commit5d62b37fb4ec9d205422d87900a10bf2b41c8ac5 (patch)
treecb4b5f8cd664c6a80d4385c2e7b643bfa8a56eae /setup.py
parent3364694f14f8a0b92ce70ca608a73966c4043256 (diff)
downloadvidslice-5d62b37fb4ec9d205422d87900a10bf2b41c8ac5.tar.gz
vidslice-5d62b37fb4ec9d205422d87900a10bf2b41c8ac5.zip
make sure the build actually works (#1)
* get ready to wrestle with build infra for three hours * put some things back where they came from * juggle more dependency stuff * it's always something * use correct python * look harder for the correct DLLs fml * correctly disable sh -x * i swear to fuckin christ * bdg voice i am going to throw myself into the sea
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 8 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index cf45e97..92300c8 100644
--- a/setup.py
+++ b/setup.py
@@ -11,10 +11,14 @@ buildOptions = dict(packages=[], excludes=[])
PYTHON_INSTALL_DIR = os.path.dirname(os.path.dirname(os.__file__))
if sys.platform == "win32":
- buildOptions['include_files'] = [
- os.path.join(PYTHON_INSTALL_DIR, 'DLLs', 'libcrypto-1_1-x64.dll'),
- os.path.join(PYTHON_INSTALL_DIR, 'DLLs', 'libssl-1_1-x64.dll'),
- ]
+ dlls_folder = os.path.join(PYTHON_INSTALL_DIR, 'DLLs')
+ targets = ['libcrypto', 'libssl']
+ include_files = []
+ for dll in os.listdir(dlls_folder):
+ for target in targets:
+ if target.startswith(target):
+ include_files.append(os.path.join(dlls_folder, dll))
+ buildOptions['include_files'] = include_files
base = 'Win32GUI' if sys.platform == 'win32' else None