aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMelody Horn <melody@boringcactus.com>2019-02-22 04:25:28 -0700
committerMelody Horn <melody@boringcactus.com>2019-02-22 04:25:28 -0700
commit64a371f232052e550d3c4832545fcfb6dab11d8e (patch)
tree7efa7f5790bbda0fc258c72357a4fff420cce4b2 /setup.py
parentd8a76e71de7dfa6692ffcb9d7a1a293d8f319157 (diff)
downloadvidslice-64a371f232052e550d3c4832545fcfb6dab11d8e.tar.gz
vidslice-64a371f232052e550d3c4832545fcfb6dab11d8e.zip
deploy
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..9aac94a
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,19 @@
+from cx_Freeze import setup, Executable
+
+# Dependencies are automatically detected, but it might need
+# fine tuning.
+buildOptions = dict(packages=[], excludes=[])
+
+import sys
+
+base = 'Win32GUI' if sys.platform == 'win32' else None
+
+executables = [
+ Executable('vidslice.py', base=base)
+]
+
+setup(name='vidslice',
+ version='1.0',
+ description='',
+ options=dict(build_exe=buildOptions),
+ executables=executables)