aboutsummaryrefslogtreecommitdiff
path: root/test-suite/Cargo.toml
diff options
context:
space:
mode:
authorest31 <est31@users.noreply.github.com>2019-10-29 15:10:15 +0100
committerAlex Crichton <alex@alexcrichton.com>2019-10-29 09:10:15 -0500
commit4673cfd79788c74c5bd6bcabe564c2dfcbd7c553 (patch)
treeee7f716b45f136725eabba6b5cd9f445ea957e7a /test-suite/Cargo.toml
parent4b05a9d34938184d5a045cc33417f57bdf2e14a8 (diff)
downloadmilf-rs-4673cfd79788c74c5bd6bcabe564c2dfcbd7c553.tar.gz
milf-rs-4673cfd79788c74c5bd6bcabe564c2dfcbd7c553.zip
Replace the test added by #349 with a bench (#351)
CI environments can be noisy and while the test worked great locally on my machine, it didn't on the CI environment. This replaces the test with a (manually tracked) benchmark. As per https://github.com/alexcrichton/toml-rs/pull/349#issuecomment-546998173
Diffstat (limited to 'test-suite/Cargo.toml')
-rw-r--r--test-suite/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/test-suite/Cargo.toml b/test-suite/Cargo.toml
index 9f500b3..4d539c8 100644
--- a/test-suite/Cargo.toml
+++ b/test-suite/Cargo.toml
@@ -5,7 +5,12 @@ authors = ["Alex Crichton <alex@alexcrichton.com>"]
publish = false
edition = "2018"
+[[bench]]
+name = "linear"
+harness = false
+
[dev-dependencies]
+bencher = "0.1"
toml = { path = ".." }
serde = { version = "1.0", features = ["derive"] }
serde_derive = "1.0"